Words and more attributs doesn't work for excerpt

Seems like there’s been a lot of helpful answers in this thread! I figured I’d chime in and share some clarifications based on my own testing.

For most attributes, L&L handles things when it comes to figuring out what’s a string and what’s a number. Adding quotes around it or not doesn’t change the way L&L understand an attribute, it’s seen as the same thing.

I don’t think the default noted in the docs actually applies. I’m still not clear on exactly why that more attribute exists and I haven’t been able to get a clear answer from a dev. Here’s some discussion on the matter from a previous thread. To answer your question though, it seems in the current release that you do have to explicitly define it if you want it to get displayed with more="...".

Personally, I’d just do this manually with something like

<Field excerpt auto=true words=25 />... <a href="{Field url}">Read more</a>

There are a bunch of new features of the `Format tag that were release recently, but that haven’t yet been documented. I’m working on getting the information I need from the dev team to be able to properly document that. In any case, keep an eye on the docs page for that tag (or just play around with the stuff mentioned in the changelog) because there’s some interesting stuff in that tag that you could probably use to achieve what yo’re looking for.

No, unfortunately. To keep the language concise and intuitive, formatting is always done with the Format tag (other than in rare cases where specific functionality is desired, like this excerpt field).

I just tested the following template in WordPress 6.3.1 running Twenty Twenty-Three theme and it worked as expected.

<Loop post_type=post count=5>
  <p><Field excerpt auto=true words=10 more="..." /></p>

Which results in the following output, as expected.

It seems there’s some customization on your site that’s causing this issue that doesn’t exist with a vanilla 6.3+ block theme installation. Maybe try disabling plugins or theme modifications to see if you can identify what’s causing the issue. I’m not seeing any incompatibility on my end.