Impossible to change a Template Name/Slug


Is it possible to change a L&L Template slug afterward?
I tried several times and it always returns to the initial slug.

Also, it would be handy to have the Slug input field in Quick Edit in the Templates list page.


1 Like

Oh i see, there’s also an editable name field where the slug appears… complicated, but editable. :wink:

Capture d’écran 2022-03-25 à 16.41.13

Following: actually, the template Name/Slug is not editable, changes are not saved.

Annoying when you realize you choosed a wrong title for the template initially and want to change afterward, because the Name/Slug is based on the initial title.
The only solution is to create a new template and trash the previous one.

Any feedback on that please?

Same problem here. I’ve been using id to refer to templates, but I want to use name, except the slugs are not what I want. If I create new templates with the slugs I want, all my id references will be bad.

Maybe it’s just you and me, but I rename stuff all the time. Plus I tend to put a lot of info in the name since there is no comment or notes field for templates.

Are you guys not able to edit and save the template name in the area highlighted in @avanti’s screenshot? Because I’m on the latest version of the plugin (2.4.4) and I’m able to rename my templates as much as I want.

Also @RichardC, I guess this would depend on what kind of info you would want to add to a note field on a template, but you could always use the Note tag and add your notes directly to the template.

Hi @benjamin, thanks for your test.
I’m on L&L 2.4.4 too and still unable to edit the template’s name.
After i update the template, the previous name is back.

But i can edit and save the template’s slug now, which changes the name!

There was something strange in this area. :wink:

Do you have any other plugins that might be adding/modifying functionality related to slugs? I have a fresh WP install and I’m not seeing that “Slug” field at the bottom of my template like you have on yours. I only have the “Name” field in the right column (the field that you showed in your second post in this thread) and I’m able to update it. I’m also able to reference it using <Template name=my-edited-template-name /> so I know it’s saving correctly.

Let me know if you’re able to figure out what’s causing that Slug field to appear on your WP installation.

You can enable the slug field at top right of the window for most of WP post types, in the Screen Options tab, it’s in WP core.

Yes, there might be an interference with another plugin on my site, it’s a test site full of stuff.
But i think i also had the same issue on a leaner site, not 100% sure.

Anyway, i have a workaround now.
Thanks much for your try and testimonial.

Oh haha, I had never thought to look there. Good to know in case anyone else needs the workaround! Well if you figure out whether there’s a plugin conflict on your site, do let me know!

Interestingly, the behaviour for me is the opposite: I can change the slug using the Name field (the one in the publish menu) but if I make the Slug field visible as you’ve shown, changing the Slug field doesn’t do anything and the template name stays as whatever is written in the Name field. This seems like the expected way that the plugin would work, but it’s at least interesting as a clue about where the issue might be coming from.

@RichardC let me know if you’re able to identify a plugin conflict that might be causing this behaviour on your installation as well. Hopefully, @avanti’s workaround works for you until either we’re able to replicate the issue you’re describing or you’re able to identify what might be causing the issue on your site.

Same issue I was facing since i first use L&L. I use permalink change related plugin like permalink manager pro to easily manipulate all the permalink in anyway I like. But this issue didn’t bug me since I also use admin column pro, added a column in admin area and enable to edit straight to the slug field, problem solve.

1 Like

I’m on the latest version and I could not change the slug either at the bottom of the page or in the Publishing section even when all other plugins were deactivated.

However, Admin Columns Pro did let me change the slug. Thanks @supremebeing88

Don’t know if this is related, and maybe I should make a separate post, but more often than not, when I’m editing a template normally and click update, the update button says saved briefly, then back to update. However, if try to close that template without making any further changes, I get the message:

Leave site?
Changes you made may not be saved.

I’m using the current version of Chrome.

1 Like

I’ve also noticed this strange behavior of the Update button of a L&L template, changing state in a weird way compared to any other post type’s edit.

Hi everyone, we’ve disabled AJAX saving in the latest release of L&L, which should resolve the issues described in this thread. We’ll continue working on a long-term solution to this so that we can reenable AJAX saving without these issues in the future for added convenience. Thanks for your patience :slight_smile:


Tested and working in 3.0, i can now change a Tangible template’s slug by editing it in the WP Slug field.
And the modification is reflected in the Publish metabox > Name field.
Directly editing this Name field is still not taken into account though, not a big deal as long as the change can be done in the Slug field.


Thanks for the test @avanti, glad to hear it’s working now and I’ll see what we can do about that name field.

1 Like