L&L Code disappeared in block editor, still showing in the front end

Hi there, so at some point in the last few days, in the back end of my website, in the block editor, my ‘Tangible Template’ blocks have disappeared, yet they are still displaying on the front end and still show in the database (when I check on phpmyadmin) for the post as well.

So in the post in question, the Tangible Template blocks (I have 2 on that post) are completely gone in the block editor - they don’t show in the live page canvas or in the ‘List View’ sidebar.
So I have no idea what has happened here - is this a bug which you have heard of before?

The problem is that I need to make changes to the code. Now I can add another tangible template block and add my updated code, but the problem is, I cannot even see the ‘old’ block in the block editor to remove it, so I have absolutely no idea how to solve this.

I tried reinstalling the latest version of Loops and Logic plugin over the top of the current one (of the same version), but that did not fix the issue.

Can anyone offer me any assistance or advice please?

Thanks in advance,


Hi Keith, that’s a really odd issue, I’ve never heard of that happening. Did this occur when you updated L&L to 4.1.3, or did something else happen on your site that caused this to occur? Have you tried the ol’ deactivate-all-the-plugins-other-than-L&L approach to troubleshoot whether this is a native issue with L&L on your site or if a conflict with another plugin is causing this?

We’ve been using L&L on our sites going back many years and I’ve never heard of Tangible Template blocks disappearing. I’ve tried looking back on some of our old testing sites and updating things and my L&L template blocks are still available in the editor. Let me know if you discover anything else about this issue that might help us replicate it since at the moment I’m at a loss. Perhaps someone else has experienced this and will chime in.

Hi! Thanks for coming back to me. No, so L&L was already running on the latest version and was running fine.
Nothing was updated or changed (as in plugins / theme / WP version) in the time since it was fine until it disappeared either. I do have about 25 editors working on the site and also its a very big site (about 4,000 pages) so there is every chance a bug has occurred somehow. And it isn’t a case that someone has deleted the blocks as like I say they are still in the database and on the front end, just not showing in the block editor.

OK I will see if there is some way I can delete the block via the database and just try re-inputting it again.

I did notice from other threads on here that there is an issue with the gutenberg plugin (I can’t save templates so I have to code it directly in the block) so maybe it’s related to that, as I am using a custom theme with gutenberg plugin installed.

Anyway thanks for your help, if I manage to solve it then I will post an update on here.



1 Like

Have you noticed whether this issue happens with only inline L&L templates or if it happens with both inline and saved templates? Have you chosen to not use saved templates because of workflow reasons or is there some functional issue that’s preventing you from using saved L&L templates?

I don’t seem to be able to find the exact commit but I’m fairly certain that particular issue was resolved in September 2023. It was related to a JS library (Lodash) not loading when the Gutenberg plugin was activated.

I may just be a WP novice, but what’s the use case for this? I’ve worked with custom themes and Gutenberg is still active as a page builder without requiring the standalone plugin. I thought the plugin’s main purpose was to act as a testbed for new features before they were released in the WP core version of Gutenberg.