Template styles tab: characters getting stripped not escaped on save


I think this might be a bug.
Some characters eg '\' are getting stripped on save from the Styes tab for templates rather than escaped.

Is preventing me from adding a icon font for template design.
Tried encoding them another way and haven’t got it to work.

.fn_icon-list:before {
content: “\e901”;

becomes content: “e901”; when saved.

Thanks for letting us know!

It was indeed a bug with escape characters being stripped from template fields, including the Style field.

It’s been solved in the newest version 2.0.5, based on information from: https://developer.wordpress.org/reference/functions/update_post_meta/#workaround

1 Like

thanks for the super quick fix!

@eliot Hey mate. Further to this. This is working well for saved templates/styles now.

In 2.0.6 - Escaped characters are being stripped somewhere in the export/import process for templates. I’ve just moved a few across sites and the escaped characters are missing in the styles again

Thanks for the information! The same workaround needed to be added to the import process, to preserve escape characters in template fields. It’s been solved in the newest plugin version.